new-system/configuration.nix
2023-12-19 08:24:05 -05:00

58 lines
1.8 KiB
Nix
Raw Permalink Blame History

This file contains ambiguous Unicode characters

This file contains Unicode characters that might be confused with other characters. If you think that this is intentional, you can safely ignore this warning. Use the Escape button to reveal them.

{ pkgs, ... }:
{
imports =
[ # Include the results of the hardware scan.
./hardware-configuration.nix
./zfs-config.nix
./common
./common/sites/fill-me-in
];
boot.loader = {
grub = {
# Use the GRUB 2 boot loader.
enable = true;
version = 2;
# efiSupport = true;
# efiInstallAsRemovable = false;
# Define on which hard drive you want to install Grub.
device = fill-me-in; # or "nodev" for efi only
};
# efi.efiSysMountPoint = "/boot/efi"; # (part of the generated default)
};
networking = {
hostName = fill-me-in; # Define your hostname.
hostId = fill-me-in; # required by ZFS
# Open ports in the firewall.
firewall.allowedTCPPorts = [ 22 ];
# firewall.allowedUDPPorts = [ ... ];
# Pick only one of the below networking options.
# networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
# networkmanager.enable = true; # Easiest to use and most distros use this by default.
};
# Set your time zone.
time.timeZone = "UTC";
# Select internationalisation properties.
i18n.defaultLocale = "en_US.UTF-8";
console = {
# keyMap = "us";
useXkbConfig = true; # use xkbOptions in tty.
};
services.xserver.layout = "us";
# This value determines the NixOS release from which the default
# settings for stateful data, like file locations and database versions
# on your system were taken. Its perfectly fine and recommended to leave
# this value at the release version of the first install of this system.
# Before changing this value read the documentation for this option
# (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
system.stateVersion = fill-me-in; # Did you read the comment?
}